Бери и делай
НовоеПопулярное
Изучай
Создавай
Улучшай

Как использовать формулы в Excel

2---
556

В Excel можно создать бесконечное множество формул. Если научиться правильно ими пользоваться, то удастся значительно упростить работу с данными. Вопреки расхожему мнению, программа является незаменимым помощником не только в профессиональных, но и в домашних делах.

«Бери и Делай» расскажет о главных принципах написания формул в Excel и поможет облегчить работу с ними.

Основные правила создания формул в Excel

  • Рабочее поле в Excel состоит из ячеек. Каждая из них имеет свой адрес, который включает в себя буквы верхней строки и цифры бокового столбца. Например, A2, B5, E9 и т. п.

  • Чтобы написать формулу, поставьте курсор на нужную ячейку. На клавиатуре нажмите знак «равно» (=). С него начинаются все формулы.

  • В каждой упрощенной формуле есть свои операторы. Так называют математические операции, которые составляют основу вычислений. Обозначения стандартные и известные еще со школы.

  • В приоритете всегда то, что стоит в скобках. Если их нет, но при этом используются несколько операторов, то обрабатываться они будут в следующей последовательности: %, ^; *, /; +, —.

  • Чтобы обозначить в формуле адрес ячейки, необязательно вводить ее вручную. Достаточно напечатать =, а затем нажать на нужную ячейку. Система автоматически поставит ее адрес.

  • После того как формула введена, остается только нажать Enter.

Пример: =A5+B3. Этой простой формулой можно вычислить сумму значений ячеек A5 и B3.

Нюансы работы с формулами

  • Чтобы было легче вводить формулы, в Excel можно воспользоваться списком функций. Они входят в состав разных формул и позволяют производить даже самые сложные вычисления. Найти их можно несколькими способами:

  1. Нажать кнопку «fx», расположенную над рабочим полем.

  2. Нажать кнопку «Вставить функцию» во вкладке «Формулы».

  3. Выбрать конкретную функцию в предложенных категориях во вкладке «Формулы».

  • Если вы хотите скопировать формулу и применить ее сразу к нескольким ячейкам, переместите курсор в левый нижний угол и, когда появится черный плюсик, потяните блок в нужном вам направлении.
  • Поскольку переменные при копировании формул меняются, такие ссылки на ячейки называют относительными. Однако иногда надо зафиксировать одно из значений, чтобы оно оставалось неизменным. Данные ссылки являются абсолютными. В них необходимо использовать знак доллара ($).
  1. $A$5 — остаются постоянными строка и столбец.
  2. A$5 — остается постоянной только строка.
  3. $A5 — не меняется только столбец.

Примеры использования функций

1. СУММ — сложение чисел. Подойдет, если надо подсчитать общую сумму аргументов. Находится среди «Математических функций». Как выглядит:

  • =СУММ(число1;число5;число9) — для переменных, которые расположены в отдаленных друг от друга ячейках.

  • =СУММ(число1:число9) — рассчитывает сумму чисел в определенном диапазоне. В примере с 1 по 9.

Пример: надо посчитать, сколько всего было потрачено денег на разные продукты. Обозначаем ячейку, где будет выводиться итоговая сумма. Находим на вкладке «Формулы» «Математические функции», выбираем «СУММ».

Заполняем аргументы:

  • Число1 — здесь либо выделяем одну из нужных ячеек, либо ставим сразу нужный диапазон. В примере B2:B8.
  • Число2 — следующее значение отдельной ячейки. Если ранее был установлен диапазон, это поле остается пустым.

2. СУММЕСЛИ — сложение чисел при соблюдении определенного условия. Позволяет посчитать числа, находящиеся в разных частях таблицы, но имеющие одинаковый параметр. Можно также найти в «Математических функциях». Как выглядит:

  • =СУММЕСЛИ(диапазон;критерий;диапазон_суммирования).

Пример: надо посчитать сумму денег, потраченную только на еду. Для этого выделяем ячейку, где будет указано искомое число. На вкладке «Формулы» выбираем «Математические», находим функцию «СУММЕСЛИ».

В появившемся окне устанавливаем аргументы:

  • Диапазон — в нем будет искаться подходящий критерий. Ставим курсор в поле «Диапазон» и выделяем нужные ячейки (в примере это A2:A8).

  • Критерий — то условие, которое должно соблюдаться при суммировании. Чтобы его обозначить, просто нажимаем на ячейку с ним. В примере выбран критерий «еда», A3.

  • Диапазон_суммирования — среди этих чисел автоматически будут выбраны те, которые подойдут под заданные ранее условия. У нас в таблице это ячейки с B2 по B8.

3. СРЗНАЧ — вычисление среднего значения. Подходит, если надо рассчитать среднее арифметическое из множества чисел. Находится среди «Статистических функций». Как выглядит:

  • =СРЗНАЧ(число1;число5;число9) — для удаленных друг от друга переменных.

  • =СРЗНАЧ(число1:число9) — для диапазона чисел.

Пример: надо вычислить среднюю зарплату сотрудников. Нажимаем на ячейку в нужной графе, находим среди функций «Статистические», выбираем «СРЗНАЧ».

Обозначаем аргументы:

  • Число1 — либо выделяем одну из ячеек, либо ставим нужный диапазон. В примере C2:C8.

  • Число2 — другое значение отдельной ячейки. Если ранее был выбран диапазон, это поле остается пустым.

4. ЕСЛИ — выполнение условия. С помощью этой функции можно проверить, был ли достигнут желаемый результат. Находится среди «Логических функций». Как выглядит:

  • =ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь).

Пример: надо узнать, кто выполнил план продаж, а кому еще есть к чему стремиться. Выделяем ячейку, где будет показан результат вычислений. Находим «Логические функции» и выбираем «ЕСЛИ».

Расписываем аргументы:

  • Лог_выражение — определяющее условие для обозначения результата. В нашем примере выручка сотрудника должна быть более 50 000, поэтому данный аргумент будет выглядеть так: B2>50000.
  • Значение_если_истина — здесь прописываем то, что будет написано в таблице, если условие выше соблюдается.
  • Значение_если_ложь — это будет прописано, если условие не было соблюдено.

Когда формула введена для одной ячейки (B2), ее надо растянуть на остальные, чтобы узнать значения для них.

5. МАКС — обозначение наибольшего значения. Удобна, когда надо узнать максимальное число из выборки. Найти можно среди «Статистических функций». Как выглядит:

  • =МАКС(число1;число5;число9) — для удаленных друг от друга переменных.
  • =МАКС(число1:число9) — для диапазона чисел.

Пример: надо узнать, какое количество гостей в заведении было максимальным. Для этого нажимаем на ячейку, куда будут выводиться данные. Находим категорию «Статистические», выбираем «МАКС».

Определяем аргументы:

  • Число1 — либо первое значение посетителей для конкретной даты, если делается выборка по определенным дням, либо диапазон. В примере выставлен интервал с B2 по B16.
  • Число2 — второе значение для нужной даты.
2---
556
Поделиться этой статьёй